Shifting issues with trailblazer

Discussion in 'The Garage' started by Odium, May 12, 2018.

  1. Odium
    Offline

    Odium Gold Member

    Joined:
    Jan 29, 2015
    Messages:
    24,753
    Thanks Received:
    3,923
    Trophy Points:
    290
    Location:
    Georgia Mountains
    Ratings:
    +21,826
    About a week ago little nuts broke on shift cable so replaced those and then it got stuck in drive so removed entire shift handle and started using cable to shift gears. Bought new shifter and it fits and is working but now it freely shifts without pushing the brake pedal down. Cable moves like its supposed to but at times now it won't let the key come out of ignition even when its in park and I can hear the doors unlock. Thinking it might be the little motor on the shifter but not entirely sure. The shifter won't LOCK in place like its supposed to and I don't understand WHY. Damn motor is 76$ which SUCKS! The cable also freely changes gears without brake pedal being pressed....
     
    • Informative Informative x 1
  2. Pogo
    Offline

    Pogo Diamond Member

    Joined:
    Dec 7, 2012
    Messages:
    93,927
    Thanks Received:
    13,947
    Trophy Points:
    2,190
    Location:
    Carolinia Agresticia; the Forest Primeval
    Ratings:
    +46,180
    It is the Deep State 'adjusting' your car. Do not interfere with Them.
     
  3. miketx
    Offline

    miketx Diamond Member

    Joined:
    Dec 25, 2015
    Messages:
    53,079
    Thanks Received:
    6,003
    Trophy Points:
    1,870
    Ratings:
    +60,579
    It has to be something with the cable adjustment or possibly the motor that unlocks it. I never experienced this problem but from my experience it has to be there in the console. What happens of you disconnect the motor? Try this also, Disconnect cable at trans. (it just snaps off) make sure it is in park. Then put the shifter in park. Then see if the cable will snap back onto the trans, under the car. If it's too short or too long the cable needs to be adjusted. It's been a long time but if you didn't change the cable it has to be up top.
     
    Last edited: May 20, 2018

Share This Page