problem with pc

Discussion in 'Computers' started by aladavlis, Dec 16, 2006.

  1. aladavlis
    Offline

    aladavlis Rookie

    Joined:
    Dec 16, 2006
    Messages:
    1
    Thanks Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hello,
    I am having trouble with my Internet explorer.It is doing some very odd things.Sometimes it will completely close the page i am visiting for no reason or it will be very slow loading pages and when i say slow i mean very very very slow for eg i tried to google something and after 10 minutes of the page trying to load i gave up.I thought that it was perhaps the topic i was searching so i tried putting in random things to see if that made any difference but it didn't.Another problem i had was when i was on a forum and clicked on a link and nothing happened i tried to open a new tab and that wouldn't work either and it would let me access any options that are in my tools menu.i had to restart my computer.Just to let you know i have high speed Internet connection.Thanks in advance to anyone that helps me with this problem.
     
  2. Mr. P
    Offline

    Mr. P Senior Member

    Joined:
    Aug 5, 2004
    Messages:
    11,329
    Thanks Received:
    618
    Trophy Points:
    48
    Location:
    South of the Mason Dixon
    Ratings:
    +620
    Dump IE and use Firefox.
     
  3. Sir Evil
    Offline

    Sir Evil Member

    Joined:
    Nov 8, 2006
    Messages:
    108
    Thanks Received:
    26
    Trophy Points:
    6
    Ratings:
    +26
    I agree with Mr. P, g with firefox. If you prefer IE make sure that you are using the lastest version, or try to reload a new install. Make sure you cleared your cache as well, it can bog you down.
     
  4. KarlMarx
    Offline

    KarlMarx Senior Member

    Joined:
    May 9, 2004
    Messages:
    3,231
    Thanks Received:
    490
    Trophy Points:
    48
    Location:
    ...
    Ratings:
    +491
    I upgraded to IE 7 a few weeks ago.....



    big mistake.


    If that's what you have, then it's IE 7 that's causing the problems. For some reason, IE 7 does not behave well with Google mail, it hangs up on attachments sometime.

    I also have Firefox on my PC. When I use that instead of IE 7, I don't have any problems at all.
     
  5. Semper Fi
    Offline

    Semper Fi VIP Member

    Joined:
    Nov 25, 2003
    Messages:
    1,772
    Thanks Received:
    130
    Trophy Points:
    83
    Location:
    Wisconsin
    Ratings:
    +130
    Im pretty sure we all have problems with political correctness (heh heh).

    But yeah, just switch to Firefox. Im personally fond of the tabs offered in firefox, so you can have multiple pages open, but all in the same window, so then the user bar or whatever on the bottom of your screen doesnt have 15 million IE boxes...or whatever.
     

Share This Page